eBay Home Page Down, Pictures Not Loading

Liz Morton ~ Founder
Liz Morton ~ Founder


Comments

eBay users are reporting a variety of technical issues tonight, but the two main ones seem to be affecting pages being down and pictures not loading/being corrupted.

Where's All The Stuff?

Users reported seeing this error message off and on throughout the day today on the home page, seller hub, make offers page and more.

C'mon ebay, I got crap to ship! LOL from Flipping
Our home page is down...
Heads up fellow sellers...another glitch is upon us. Check it out.

Photos Not Loading / Photos Corrupted

This one seems to be affecting both sellers on the listing side and buyers on the search side as well.

Can’t relist: eBay says photos “corrupted”
2 items relisted perfectly fine on 12/14. Then they sold yesterday 12/15. Today, 12/16, I’m trying to “sell similar” items again (more of the same), but getting message in listing form that the photos are “corrupted”. I can usually just click on “sell similar” with no problems and the same list…

2 items relisted perfectly fine on 12/14.

Then they sold yesterday 12/15.

Today, 12/16, I'm trying to "sell similar" items again (more of the same), but getting message in listing form that the photos are "corrupted". I can usually just click on "sell similar" with no problems and the same listings get posted right away.

If my photos are "corrupted" then eBay did it... and they need to fix it.

Is anyone else experiencing this?

No longer able to see any images in search - need suggestions on what else to do
Today after clearing my cache on Safari 14.1.2 on MacBook Pro 16″ no images display in the Ebay search. I have cleared cache and history again, rebooted multiple times, but nothing works. I can’t figure out what else to do to get the images to start loading again. Never had this problem before. See…

Today after clearing my cache on Safari 14.1.2 on MacBook Pro 16" no images display in the Ebay search. I have cleared cache and history again, rebooted multiple times, but nothing works. I can't figure out what else to do to get the images to start loading again. Never had this problem before. See attached pic.

All the other pictures show up, if you click on the item then all the images appear, and they show fine on the home page, but if you search ANY term, then zero images appear like below:

What else should I do? It's not the computer, Firefox works.

Screen-Shot-2021-12-16-at-4.56.27-PM


Are you seeing other technical problems with eBay today? Let me know in the comments below!

Tech IssueseBay

Support VAR