eBay Sellers Unable To Generate Labels, From Zip Code Not Valid

Liz Morton
Liz Morton


Comments

Several eBay sellers in Canada have run into a strange issue preventing them from printing shipping labels with an error claiming their "from" zip code is invalid.

In every case reported so far, these sellers are registered in Canada, but take their items across the US border to ship - thus their usual "ship from" address and zip code is in the US.

It was not possible to generate the label. Ship From ZIP code is not valid.
Started November 17 /2023 can’t purchase label from ebay , gives me error : It was not possible to generate the label. Ship From ZIP code is not valid. Been using same shipping address for the last year and was told from rep at ebay that it is a problem and will be fixed within 24 hours On Friday N…

Started November 17 /2023 can't purchase label from ebay , gives me error:

It was not possible to generate the label. Ship From ZIP code is not valid.

Been using same shipping address for the last year and was told from rep at ebay that it is a problem and will be fixed within 24 hours On Friday November 17/2023 . Saturday , Sunday , Monday and still not working . Tried to purchase in bulk , same error .

I have had this problem too since Saturday. So has a buddy. I have been printing USPS shipping labels for 10 years. Even though I am in Canada I have my USPS shipments driven across the border and this has never been an issue before. All of a sudden it is a problem.

1 Chat, 2 Calls (including an escalation to a supervisor) and 1 email to eBay and nobody is able to tell me what the issue is or when it is being resolved. You would think that if this was a widespread problem (i.e. every seller in Canada who ships via USPS) eBay would have received a lot of support calls and all of the agents would be able to be able to access information on this issue and tell me more.

I have a service request number and an IT ticket number but when I call nobody can give me a straight answer as to the reason for the problem, status of either ticket or a timeline for resolution. Extremely frustrating to say the least.

I'm having the same issue. First experienced it in one store on Nov 20, 2023, but the other store is working fine, no issues with purchasing shipping labels. Ebay promised to look into it with no timeline on resolution...

It was not possible to generate the label. Ship From ZIP code is not valid. The zip code is correct
eBay does not let me purchase shipping labels. it says It was not possible to generate the label. Ship From ZIP code is not valid. The zip code is correct

eBay does not let me purchase shipping labels. it says It was not possible to generate the label. Ship From ZIP code is not valid. The zip code is correct

One seller discovered the issue appears to be that eBay has changed something in the coding for creating labels that is either pulling information from the wrong place or just simply not allowing the "return" address to be in a different country - changing their return address to be the same as the "from" address corrected the error and allowed labels to be printed.

Why isn’t shipping working today?
I keep getting this, doesn’t matter which listing I try to print shipping on: Going somewhere else to print labels is going to be lots of extra work, why can’t I print them on eBay? C.

My "return address" for people sending stuff back is in Canada. I changed it to the Niagara Falls NY address of Chit Chats (same as the sending address), and my label printed!

This seems to be what resolved the issue, it doesn't like the return address to be in a different country than the send from address.

I went to look at my label. It actually printed what I put in the "return address" on the label (which was formerly my address in Canada, the purpose of that was for buyers to return items to Canada), it did not pull my "send from" address in my address profile. The send from address was modified to remove slashes and parenthesis when I was trouble shooting yesterday, and I never changed it back. I updated my return to address to be what I know as correct for Chit Chats, and that's what it pulled for the label...

...So for anyone else having this issue, change your "return to" address to your US address, and it will pull from there for the label and print that on it. If you have another country in there, USPS won't understand. Something's changed with the web programming to make our return to address the ship from address now, and the ship from address in the profile doesn't seem to be used (even though it shows up on the right hand side when I go to print my label).

Another seller was able to confirm that changing the "return" address fixed the problem.

Can confirm that I was also able to generate the USPS label today after setting the "return address" in the account setting to the US address. (though the Ship From/Return address option in the label printing section had always been the US address even before the change)

Judging solely from the timing and that only USPS labels were showing this error, I guess ebay did change something internally regarding USPS labels even though they are not going to increase the rates. Or maybe changes in the system was actually made to ensure the new rates don't reflect on ebay buy shipping, and sellers with return addresses in foreign countries got caught up in this.

Are you experiencing this issue with printing labels from Canada while using a US address? Let us know in the comments below!

eBayShipping

Liz Morton Twitter Facebook LinkedIn

Liz Morton is a seasoned ecommerce pro with 17 years of online marketplace sales experience, providing commentary, analysis & news about eBay, Etsy, Amazon, Shopify & more at Value Added Resource!