eBay's Traffic report page appears to be experiencing a glitch today causing it to incorrectly show zero impressions and views.

What is going on with Ebay technical
Today, on GrandmasJewelry123, traffic shows zero. No promotions, no traffic all month. That’s not accurate because there have been sales this month, so what is going on with ebay traffic statistics, and what is going on with ebay traffic period?

Today, on GrandmasJewelry123, traffic shows zero. No promotions, no traffic all month. That's not accurate because there have been sales this month, so what is going on with ebay traffic statistics, and what is going on with ebay traffic period?

I checked the Traffic page in Seller Hub and sure enough, it shows 0 for impressions and views, which is definitely not accurate.  Interestingly, it's not just in the charts, it's also showing zeros in the bottom Active Listings section as well.

Also interesting to note that it is still accurately reflecting sales numbers, so whatever the glitch is appears to only be affecting the reporting of impressions and views.

The URL for this page is https://www.ebay.com/sh/performance/traffic

I may have found a temporary work around - it appears that if you filter the report by date (even if you choose the same dates that the page defaults to) that forces a change to the URL and then it does show the data again.

URL for this page is : https://www.ebay.com/sh/performance/traffic?filter=changed_date%3AstartDate%2Cdate_range%3A[2021-10-08..2021-11-07]

Comments